Vulnerability · Published May 13, 2025 · Assigned by GitHub_M
CVE-2025-31493Path traversal of collection names during file system lookup
Medium 6.3
In plain English
A medium-severity path traversal in kirby from getkirby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `collection()` helper or `$kirby->collection()` method with a dynamic collection name (such as a collection name that depends on request or user data). Sites that only use fixed calls to the `collection()` helper/`$kirby->collection()` method (i.e. calls with a simple string for the collection name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the collections root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic collection names, such as `collection('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have added a check for the collection path that ensures that the resulting path is contained within the configured collections root. Collection paths that point outside of the collections root will not be loaded.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | getkirby/cms | 3.9.8.3 | GHSA-x275-h9j4-7p4h |
| Packagist | getkirby/cms | 3.10.1.2 | GHSA-x275-h9j4-7p4h |
| Packagist | getkirby/cms | 4.7.1 | GHSA-x275-h9j4-7p4h |
Affected products (as reported)
Weakness: CWE-22, CWE-23 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-x275-h9j4-7p4h x_refsource_CONFIRM
- https://github.com/getkirby/kirby/releases/tag/3.10.1.2 x_refsource_MISC
- https://github.com/getkirby/kirby/releases/tag/3.9.8.3 x_refsource_MISC
- https://github.com/getkirby/kirby/releases/tag/4.7.1 x_refsource_MISC