Vulnerability · Published Apr 3, 2025 · Assigned by GitHub_M

CVE-2025-31481GraphQL query operations security can be bypassed

High 7.5

In plain English

A high-severity incorrect authorization in core from api-platform. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 58.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Using the Relay special node type you can bypass the configured security on an operation. This vulnerability is fixed in 4.0.22 and 3.4.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistapi-platform/core4.0.22GHSA-cg3c-245w-728m
Packagistapi-platform/core3.4.17GHSA-cg3c-245w-728m
Packagistapi-platform/core4.1.5GHSA-cg3c-245w-728m
Packagistapi-platform/graphql4.0.22GHSA-cg3c-245w-728m
Packagistapi-platform/graphql3.4.17GHSA-cg3c-245w-728m
Packagistapi-platform/graphql4.1.5GHSA-cg3c-245w-728m

Affected products (as reported)

VendorProductVersions
api-platform core >= 4.0.0, < 4.0.22< 3.4.17

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References