Vulnerability · Published Apr 4, 2025 · Assigned by GitHub_M
CVE-2025-31480aiven-extras allows PostgreSQL Privilege Escalation through format function
Critical 9.1
In plain English
A critical-severity security flaw in aiven-extras from aiven. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
aiven-extras is a PostgreSQL extension. This is a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages the format function not being schema-prefixed. Affected users should install 1.1.16 and ensure they run the latest version issuing ALTER EXTENSION aiven_extras UPDATE TO '1.1.16' after installing it. This needs to happen in each database aiven_extras has been installed in.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aiven | aiven-extras | < 1.1.16 |
Weakness: CWE-426 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H