Vulnerability · Published Jul 29, 2025 · Assigned by apple

CVE-2025-31278

High 8.8

In plain English

A high-severity memory corruption in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.2%top 30.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed with improved memory handling. This issue is fixed in Safari 18.6, iOS 18.6 and iPadOS 18.6, iPadOS 17.7.9, macOS Sequoia 15.6, tvOS 18.6, visionOS 2.6, watchOS 11.6. Processing maliciously crafted web content may lead to memory corruption.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.48.5-1.el8_10ALSA-2025:13780
AlmaLinux:9webkit2gtk32.48.5-1.el9_6ALSA-2025:13782
AlmaLinux:8webkit2gtk3-devel2.48.5-1.el8_10ALSA-2025:13780
AlmaLinux:9webkit2gtk3-devel2.48.5-1.el9_6ALSA-2025:13782
AlmaLinux:8webkit2gtk3-jsc2.48.5-1.el8_10ALSA-2025:13780
AlmaLinux:9webkit2gtk3-jsc2.48.5-1.el9_6ALSA-2025:13782
AlmaLinux:8webkit2gtk3-jsc-devel2.48.5-1.el8_10ALSA-2025:13780
AlmaLinux:9webkit2gtk3-jsc-devel2.48.5-1.el9_6ALSA-2025:13782
Debian:12webkit2gtk2.48.5-1~deb12u1DEBIAN-CVE-2025-31278
Debian:12webkit2gtk2.48.5-1~deb12u1DSA-5978-1
Debian:13webkit2gtk2.48.5-1~deb13u1DEBIAN-CVE-2025-31278
Debian:13webkit2gtk2.48.5-1~deb13u1DSA-5978-1
Debian:14webkit2gtk2.48.5-1DEBIAN-CVE-2025-31278
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-31278
Debian:13wpewebkitno fix listedDEBIAN-CVE-2025-31278
Debian:14wpewebkit2.48.5-1DEBIAN-CVE-2025-31278
Rocky Linux:8webkit2gtk30:2.48.5-1.el8_10RLSA-2025:13780
Rocky Linux:9webkit2gtk30:2.48.5-1.el9_6RLSA-2025:13782
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-31278
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-31278
Ubuntu:22.04:LTSwebkit2gtk2.48.5-0ubuntu0.22.04.1UBUNTU-CVE-2025-31278
Ubuntu:22.04:LTSwebkit2gtk2.48.5-0ubuntu0.22.04.1USN-7702-1
Ubuntu:24.04:LTSwebkit2gtk2.48.5-0ubuntu0.24.04.1USN-7702-1
Ubuntu:24.04:LTSwebkit2gtk2.48.5-0ubuntu0.24.04.1UBUNTU-CVE-2025-31278
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-31278

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.6
Apple iOS and iPadOS 0 – before 18.6
Apple iPadOS 0 – before 17.7.9
Apple macOS 0 – before 15.6
Apple tvOS 0 – before 18.6
Apple visionOS 0 – before 2.6
Apple watchOS 0 – before 11.6

Weakness: CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References