Vulnerability · Published May 12, 2025 · Assigned by apple

CVE-2025-31257

Medium 4.7

In plain English

A medium-severity memory corruption in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.7Medium
Exploit odds (30 days)1.1%top 34.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

This issue was addressed with improved memory handling. This issue is fixed in Safari 18.5, iOS 18.5 and iPadOS 18.5, macOS Sequoia 15.5, tvOS 18.5, visionOS 2.5, watchOS 11.5. Processing maliciously crafted web content may lead to an unexpected Safari crash.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.48.2-1.el8_10ALSA-2025:8046
AlmaLinux:9webkit2gtk32.48.2-1.el9_6ALSA-2025:7995
AlmaLinux:8webkit2gtk3-devel2.48.2-1.el8_10ALSA-2025:8046
AlmaLinux:9webkit2gtk3-devel2.48.2-1.el9_6ALSA-2025:7995
AlmaLinux:8webkit2gtk3-jsc2.48.2-1.el8_10ALSA-2025:8046
AlmaLinux:9webkit2gtk3-jsc2.48.2-1.el9_6ALSA-2025:7995
AlmaLinux:8webkit2gtk3-jsc-devel2.48.2-1.el8_10ALSA-2025:8046
AlmaLinux:9webkit2gtk3-jsc-devel2.48.2-1.el9_6ALSA-2025:7995
Debian:12webkit2gtk2.48.3-1~deb12u1DEBIAN-CVE-2025-31257
Debian:12webkit2gtk2.48.3-1~deb12u1DSA-5937-1
Debian:13webkit2gtk2.48.2-1DEBIAN-CVE-2025-31257
Debian:14webkit2gtk2.48.2-1DEBIAN-CVE-2025-31257
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-31257
Debian:13wpewebkit2.48.2-1DEBIAN-CVE-2025-31257
Debian:14wpewebkit2.48.2-1DEBIAN-CVE-2025-31257
Rocky Linux:8webkit2gtk30:2.48.2-1.el8_10RLSA-2025:8046
Rocky Linux:9webkit2gtk30:2.48.2-1.el9_6RLSA-2025:7995
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-31257
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-31257
Ubuntu:22.04:LTSwebkit2gtk2.48.3-0ubuntu0.22.04.1USN-7566-1
Ubuntu:22.04:LTSwebkit2gtk2.48.3-0ubuntu0.22.04.1UBUNTU-CVE-2025-31257
Ubuntu:24.04:LTSwebkit2gtk2.48.3-0ubuntu0.24.04.1UBUNTU-CVE-2025-31257
Ubuntu:24.04:LTSwebkit2gtk2.48.3-0ubuntu0.24.04.1USN-7566-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-31257

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.5
Apple iOS and iPadOS 0 – before 18.5
Apple macOS 0 – before 15.5
Apple tvOS 0 – before 18.5
Apple visionOS 0 – before 2.5
Apple watchOS 0 – before 11.5

Weakness: CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L

References