Vulnerability · Published Apr 1, 2025 · Assigned by GitHub_M
CVE-2025-31132Raven allows Remote Code Execution due to improper validation
High 8.1
In plain English
A high-severity improper input validation in raven from The-Commit-Company. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities).
Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.6%top 49.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Raven is an open-source messaging platform. A vulnerability allowed any logged in user to execute code via an API endpoint. This vulnerability is fixed in 2.1.10.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The-Commit-Company | raven | < 2.1.10 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N