Vulnerability · Published Mar 31, 2025 · Assigned by GitHub_M

CVE-2025-31128gifplayer XSS vulnerability

Medium 6.9

In plain English

A medium-severity cross-site scripting in gifplayer from rubentd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.5%top 57.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

gifplayer is a customizable jquery plugin to play and stop animated gifs. gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagist:https://packages.drupal.org/8drupal/gifplayer1.5.0, 2.0.4DRUPAL-CONTRIB-2025-032
npmgifplayer0.3.7GHSA-gr7w-hmch-25g7

Affected products (as reported)

VendorProductVersions
rubentd gifplayer < 0.3.7

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References