Vulnerability · Published Apr 3, 2025 · Assigned by GitHub_M

CVE-2025-31119CWE-470 in generator-jhipster-entity-audit when having Javers selected as Entity Audit Framework

High 7.7

In plain English

A high-severity security flaw in generator-jhipster-entity-audit from jhipster. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.5%top 54.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

generator-jhipster-entity-audit is a JHipster module to enable entity audit and audit log page. Prior to 5.9.1, generator-jhipster-entity-audit allows unsafe reflection when having Javers selected as Entity Audit Framework. If an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution. This vulnerability is fixed in 5.9.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmgenerator-jhipster-entity-audit5.9.1GHSA-7rmp-3g9f-cvq8

Affected products (as reported)

VendorProductVersions
jhipster generator-jhipster-entity-audit < 5.9.1

Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

References