Vulnerability · Published Mar 31, 2025 · Assigned by apple

CVE-2025-30427

Medium 4.3

In plain English

A medium-severity use-after-free in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.8%top 42.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A use-after-free issue was addressed with improved memory management. This issue is fixed in Safari 18.4, iOS 18.4 and iPadOS 18.4, iPadOS 17.7.6, macOS Sequoia 15.4, tvOS 18.4, visionOS 2.4, watchOS 11.4. Processing maliciously crafted web content may lead to an unexpected Safari crash.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk32.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk32.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-devel2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-devel2.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk3-devel2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-jsc2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-jsc2.48.1-1.el9_5ALSA-2025:3713
AlmaLinux:9webkit2gtk3-jsc2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:8webkit2gtk3-jsc-devel2.48.1-1.el8_10ALSA-2025:3974
AlmaLinux:9webkit2gtk3-jsc-devel2.48.1-1.el9_6ALSA-2025:7387
AlmaLinux:9webkit2gtk3-jsc-devel2.48.1-1.el9_5ALSA-2025:3713
Debian:12webkit2gtk2.48.1-2~deb12u1DSA-5899-1
Debian:12webkit2gtk2.48.1-2~deb12u1DEBIAN-CVE-2025-30427
Debian:13webkit2gtk2.48.1-1DEBIAN-CVE-2025-30427
Debian:14webkit2gtk2.48.1-1DEBIAN-CVE-2025-30427
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-30427
Debian:13wpewebkit2.48.1-1DEBIAN-CVE-2025-30427
Debian:14wpewebkit2.48.1-1DEBIAN-CVE-2025-30427
Rocky Linux:8webkit2gtk30:2.48.1-1.el8_10RLSA-2025:3974
Rocky Linux:9webkit2gtk30:2.48.1-1.el9_5RLSA-2025:7387
Rocky Linux:9webkit2gtk30:2.48.1-1.el9_5RLSA-2025:3713
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-30427
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-30427
Ubuntu:22.04:LTSwebkit2gtk2.48.1-0ubuntu0.22.04.1UBUNTU-CVE-2025-30427
Ubuntu:22.04:LTSwebkit2gtk2.48.1-0ubuntu0.22.04.1USN-7436-1
Ubuntu:24.04:LTSwebkit2gtk2.48.1-0ubuntu0.24.04.1USN-7436-1
Ubuntu:24.04:LTSwebkit2gtk2.48.1-0ubuntu0.24.04.1UBUNTU-CVE-2025-30427
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-30427

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 18.4
Apple iOS and iPadOS 0 – before 18.4
Apple iPadOS 0 – before 17.7.6
Apple macOS 0 – before 15.4
Apple tvOS 0 – before 18.4
Apple visionOS 0 – before 2.4
Apple watchOS 0 – before 11.4

Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References