Vulnerability · Published Apr 8, 2025 · Assigned by GitHub_M
CVE-2025-30166Pimcore's Admin Classic Bundle allows HTML Injection
Low 1.8
In plain English
A low-severity cross-site scripting in admin-ui-classic-bundle from pimcore. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content. The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible. This vulnerability is fixed in 1.7.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | pimcore/admin-ui-classic-bundle | 1.7.6 | GHSA-x82r-6j37-vrgg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pimcore | admin-ui-classic-bundle | < 1.7.6 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N