Vulnerability · Published Apr 8, 2025 · Assigned by GitHub_M

CVE-2025-30151Shopware allows Denial Of Service via password length

High 7.5

In plain English

A high-severity improper input validation in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.6.10.3GHSA-cgfj-hj93-rmh2
Packagistshopware/core6.7.0.0-rc2GHSA-cgfj-hj93-rmh2
Packagistshopware/core6.5.8.17GHSA-cgfj-hj93-rmh2
Packagistshopware/platform6.6.10.3GHSA-cgfj-hj93-rmh2
Packagistshopware/platform6.7.0.0-rc2GHSA-cgfj-hj93-rmh2
Packagistshopware/platform6.5.8.17GHSA-cgfj-hj93-rmh2

Affected products (as reported)

VendorProductVersions
shopware shopware < 6.5.8.17>= 6.6.0.0, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References