Vulnerability · Published Apr 8, 2025 · Assigned by GitHub_M

CVE-2025-30150Shopware 6 allows attackers to check for registered accounts through the store-api

Medium 5.5

In plain English

A medium-severity security flaw in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.5Medium
Exploit odds (30 days)0.4%top 64.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Through the store-api it is possible as a attacker to check if a specific e-mail address has an account in the shop. Using the store-api endpoint /store-api/account/recovery-password you get the response, which indicates clearly that there is no account for this customer. In contrast you get a success response if the account was found. This vulnerability is fixed in Shopware 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.6.10.3GHSA-hh7j-6x3q-f52h
Packagistshopware/core6.7.0.0-rc2GHSA-hh7j-6x3q-f52h
Packagistshopware/core6.5.8.18GHSA-hh7j-6x3q-f52h
Packagistshopware/platform6.6.10.3GHSA-hh7j-6x3q-f52h
Packagistshopware/platform6.7.0.0-rc2GHSA-hh7j-6x3q-f52h
Packagistshopware/platform6.5.8.18GHSA-hh7j-6x3q-f52h

Affected products (as reported)

VendorProductVersions
shopware shopware < 6.5.8.17>= 6.6.0.0, < 6.6.10.3>= 6.7.0.0-rc1, < 6.7.0.0-rc2

Weakness: CWE-204 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/U:Green

References