Vulnerability · Published Mar 19, 2025 · Assigned by GitHub_M
CVE-2025-29926The WikiManager REST API allows any user to create wikis
High 7.9
In plain English
A high-severity security flaw in xwiki-platform from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Platform is a generic wiki platform. Prior to 15.10.15, 16.4.6, and 16.10.0, any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.platform:xwiki-platform-wiki-rest-default | 15.10.15 | GHSA-gfp2-6qhm-7x43 |
| Maven | org.xwiki.platform:xwiki-platform-wiki-rest-default | 16.4.6 | GHSA-gfp2-6qhm-7x43 |
| Maven | org.xwiki.platform:xwiki-platform-wiki-rest-default | 16.10.0 | GHSA-gfp2-6qhm-7x43 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-platform | >= 5.4-rc-1, < 15.10.15>= 16.0.0-rc-1, < 16.4.6>= 16.5.0-rc-1, < 16.10.0 |
Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gfp2-6qhm-7x43 x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-platform/commit/82aa670106c7f5e6238ca6ed59a52d1800e05b99 x_refsource_MISC
- https://jira.xwiki.org/browse/XWIKI-22490 x_refsource_MISC