Vulnerability · Published Mar 19, 2025 · Assigned by GitHub_M

CVE-2025-29924XWiki uses the wrong wiki reference in AuthorizationManager

High 8.7

In plain English

A high-severity privilege mismanagement in xwiki-platform from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 65.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, it's possible for an user to get access to private information through the REST API - but could also be through another API - when a sub wiki is using "Prevent unregistered users to view pages". The vulnerability only affects subwikis, and it only concerns specific right options such as "Prevent unregistered users to view pages". or "Prevent unregistered users to edit pages". It's possible to detect the vulnerability by enabling "Prevent unregistered users to view pages" and then trying to access a page through the REST API without using any credentials. The vulnerability has been patched in XWiki 15.10.14, 16.4.6 and 16.10.0RC1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-security-authorization-api15.10.14GHSA-gq32-758c-3wm3
Mavenorg.xwiki.platform:xwiki-platform-security-authorization-api16.4.6GHSA-gq32-758c-3wm3
Mavenorg.xwiki.platform:xwiki-platform-security-authorization-api16.10.0-rc-1GHSA-gq32-758c-3wm3

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform >= 6.1-rc-1, < 15.10.14>= 16.0.0-rc-1, < 16.4.6>= 16.5.0-rc-1, < 16.10.0-rc-1

Weakness: CWE-269 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References