Vulnerability · Published Mar 18, 2025 · Assigned by GitHub_M

CVE-2025-29790Contao allows cross-site scripting through SVG uploads

Medium 4.8

In plain English

A medium-severity cross-site scripting in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.8Medium
Exploit odds (30 days)0.2%top 86.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Contao is an Open Source CMS. Users can upload SVG files with malicious code, which is then executed in the back end and/or front end. This vulnerability is fixed in Contao 4.13.54, 5.3.30, or 5.5.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcontao/core-bundle4.13.54GHSA-vqqr-fgmh-f626
Packagistcontao/core-bundle5.3.30GHSA-vqqr-fgmh-f626
Packagistcontao/core-bundle5.5.6GHSA-vqqr-fgmh-f626

Affected products (as reported)

VendorProductVersions
contao contao >= 4.0.0, < 4.13.54>= 5.0.0, < 5.3.30>= 5.4.0, < 5.5.6

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References