Vulnerability · Published Mar 17, 2025 · Assigned by GitHub_M

CVE-2025-29788Sylius PayPal Plugin Payment Amount Manipulation Vulnerability

Medium 6.5

In plain English

A medium-severity security flaw in PayPalPlugin from Sylius. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 56.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. A vulnerability in versions prior to 1.6.1, 1.7.1, and 2.0.1 allows users to manipulate the final payment amount processed by PayPal. If a user modifies the item quantity in their shopping cart after initiating the PayPal Express Checkout process, PayPal will not receive the updated total amount. As a result, PayPal captures only the initially transmitted amount, while Sylius incorrectly considers the order fully paid based on the modified total. This flaw can be exploited both accidentally and intentionally, potentially enabling fraud by allowing customers to pay less than the actual order value. Attackers can intentionally pay less than the actual total order amount, business owners may suffer financial losses due to underpaid orders, and integrity of payment processing is compromised. The issue is fixed in versions 1.6.1, 1.7.1, 2.0.1, and above. To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite `ProcessPayPalOrderAction`, `CompletePayPalOrderFromPaymentPageAction`, and `CaptureAction` with modified logic.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistsylius/paypal-plugin1.6.1GHSA-pqq3-q84h-pj6x
Packagistsylius/paypal-plugin1.7.1GHSA-pqq3-q84h-pj6x
Packagistsylius/paypal-plugin2.0.1GHSA-pqq3-q84h-pj6x

Affected products (as reported)

VendorProductVersions
Sylius PayPalPlugin < 1.6.1>= 1.7, < 1.7.1>= 2.0, < 2.0.1

Weakness: CWE-472 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References