Vulnerability · Published Mar 13, 2025 · Assigned by GitHub_M

CVE-2025-29768Vim vulnerable to potential data loss with zip.vim and special crafted zip files

Medium 4.4

In plain English

A medium-severity argument injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted zip files in versions prior to 9.1.1198. The impact is medium because a user must be made to view such an archive with Vim and then press 'x' on such a strange filename. The issue has been fixed as of Vim patch v9.1.1198.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22vim9.1.1202-r0ALPINE-CVE-2025-29768
Alpine:v3.23vim9.1.1202-r0ALPINE-CVE-2025-29768
Alpine:v3.24vim9.1.1202-r0ALPINE-CVE-2025-29768
Debian:12vimno fix listedDEBIAN-CVE-2025-29768
Debian:13vim2:9.1.1230-1DEBIAN-CVE-2025-29768
Debian:14vim2:9.1.1230-1DEBIAN-CVE-2025-29768

Affected products (as reported)

VendorProductVersions
vim vim < 9.1.1198

Weakness: CWE-88 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References