Vulnerability · Published Jun 23, 2025 · Assigned by @huntr_ai
CVE-2025-2828SSRF Vulnerability in RequestsToolkit in langchain-ai/langchain
High 8.4
In plain English
A high-severity server-side request forgery in langchain-ai/langchain from langchain-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 21.0% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | langchain-community | 0.0.28 | GHSA-h5gc-rm8j-5gpr |
| PyPI | langchain-community | 0.0.28 | PYSEC-2025-70 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| langchain-ai | langchain-ai/langchain | unspecified – before 0.0.28 |
Weakness: CWE-918 · Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H