Vulnerability · Published Mar 12, 2025 · Assigned by apache
CVE-2025-27867Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin
Medium 5.6
In plain English
A medium-severity cross-site scripting in Apache Felix HTTP Webconsole Plugin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.felix:org.apache.felix.http.webconsoleplugin | 1.2.2 | GHSA-2cv6-4f2r-jq2c |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Felix HTTP Webconsole Plugin | 1.x – through 1.2.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L