Vulnerability · Published Mar 7, 2025 · Assigned by GitHub_M
CVE-2025-27603XWiki Confluence Migrator Pro allows Remote Code Execution via unescaped translations
Critical 9.1
In plain English
A critical-severity security flaw in application-confluence-migrator-pro from xwikisas. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Confluence Migrator Pro helps admins to import confluence packages into their XWiki instance. A user that doesn't have programming rights can execute arbitrary code due to an unescaped translation when creating a page using the Migration Page template. This vulnerability is fixed in 1.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.xwiki.confluencepro:application-confluence-migrator-pro-ui | 1.2.0 | GHSA-6qvp-39mm-95v8 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwikisas | application-confluence-migrator-pro | > 1.0, < 1.2.0 |
Weakness: CWE-95 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H