Vulnerability · Published Mar 11, 2025 · Assigned by GitHub_M

CVE-2025-27601Umbraco Allows Improper API Access Control to Low-Privilege Users to Data Type Functionality

Medium 4.3

In plain English

A medium-severity incorrect authorization in Umbraco-CMS from umbraco. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.3%top 74.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Umbraco is a free and open source .NET content management system. An improper API access control issue has been identified Umbraco's API management package prior to versions 15.2.3 and 14.3.3, allowing low-privilege, authenticated users to create and update data type information that should be restricted to users with access to the settings section. The issue is patched in versions 15.2.3 and 14.3.3. No known workarounds are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGetumbraco.cms.api.management15.2.3GHSA-6ffg-mjg7-585x
NuGetumbraco.cms.api.management14.3.3GHSA-6ffg-mjg7-585x

Affected products (as reported)

VendorProductVersions
umbraco Umbraco-CMS >= 15.0.0-rc1, < 15.2.3< 14.3.3

Weakness: CWE-285, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References