Vulnerability · Published Mar 5, 2025 · Assigned by GitHub_M

CVE-2025-27515Laravel has a File Validation Bypass

Medium 6.9

In plain English

A medium-severity security flaw in framework from laravel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.7%top 44.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Laravel is a web application framework. When using wildcard validation to validate a given file or image field (`files.*`), a user-crafted malicious request could potentially bypass the validation rules. This vulnerability is fixed in 11.44.1 and 12.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-laravel-frameworkno fix listedDEBIAN-CVE-2025-27515
Debian:13php-laravel-framework10.48.29+dfsg-1DEBIAN-CVE-2025-27515
Debian:14php-laravel-framework10.48.29+dfsg-1DEBIAN-CVE-2025-27515
Packagistlaravel/framework12.1.1GHSA-78fx-h6xr-vch4
Packagistlaravel/framework11.44.1GHSA-78fx-h6xr-vch4
Packagistlaravel/framework10.48.29GHSA-78fx-h6xr-vch4

Affected products (as reported)

VendorProductVersions
laravel framework >= 12.0.0, < 12.1.1< 11.44.1

Weakness: CWE-155 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References