Vulnerability · Published Jun 10, 2025 · Assigned by GitHub_M

CVE-2025-27505GeoServer Missing Authorization on REST API Index

Medium 5.3

In plain English

A medium-severity missing authorization in geoserver from geoserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.2%top 32.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei

Official description

GeoServer is an open source server that allows users to share and edit geospatial data. It is possible to bypass the default REST API security and access the index page. The REST API security handles rest and its subpaths but not rest with an extension (e.g., rest.html). The REST API index can disclose whether certain extensions are installed. This vulnerability is fixed in 2.26.3 and 2.25.6. As a workaround, in ${GEOSERVER_DATA_DIR}/security/config.xml, change the paths for the rest filter to /rest.*,/rest/** and change the paths for the gwc filter to /gwc/rest.*,/gwc/rest/** and restart GeoServer.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.geoserver.web:gs-web-app2.26.3GHSA-h86g-x8mm-78m5
Mavenorg.geoserver.web:gs-web-app2.25.6GHSA-h86g-x8mm-78m5
Mavenorg.geoserver:gs-rest2.26.3GHSA-h86g-x8mm-78m5
Mavenorg.geoserver:gs-rest2.25.6GHSA-h86g-x8mm-78m5

Affected products (as reported)

VendorProductVersions
geoserver geoserver >= 2.26.0, < 2.26.3< 2.25.6

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References