Vulnerability · Published Mar 5, 2025 · Assigned by GitHub_M
CVE-2025-27412REDAXO allows Authenticated Reflected Cross Site Scripting - packages installation
Medium 6.1
In plain English
A medium-severity cross-site scripting in redaxo from redaxo. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 78.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
REDAXO is a PHP-based CMS. In Redaxo from 5.0.0 through 5.18.2, the rex-api-result parameter is vulnerable to Reflected cross-site scripting (XSS) on the page of AddOns. This vulnerability is fixed in 5.18.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | redaxo/source | 5.18.3 | GHSA-8366-xmgf-334f |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/redaxo/redaxo/security/advisories/GHSA-8366-xmgf-334f x_refsource_CONFIRM