Vulnerability · Published Feb 25, 2025 · Assigned by GitHub_M
CVE-2025-27146Matrix IRC Bridge allows IRC command injection to own puppeted user
Low 2.7
In plain English
A low-severity command injection in matrix-appservice-irc from matrix-org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
matrix-appservice-irc is a Node.js IRC bridge for Matrix. The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user. The vulnerability has been patched in matrix-appservice-irc version 3.0.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | matrix-appservice-irc | 3.0.4 | GHSA-5mvm-89c9-9gm5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| matrix-org | matrix-appservice-irc | < 3.0.4 |
Weakness: CWE-77, CWE-88 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N