Vulnerability · Published Mar 4, 2025 · Assigned by GitHub_M

CVE-2025-27111Escape Sequence Injection vulnerability in Rack lead to Possible Log Injection

Medium 6.9

In plain English

A medium-severity security flaw in rack from rack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.8%top 44.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Rack is a modular Ruby web server interface. The Rack::Sendfile middleware logs unsanitised header values from the X-Sendfile-Type header. An attacker can exploit this by injecting escape sequences (such as newline characters) into the header, resulting in log injection. This vulnerability is fixed in 2.2.12, 3.0.13, and 3.1.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-rack2.2.13-1~deb12u1DEBIAN-CVE-2025-27111
Debian:12ruby-rack2.2.13-1~deb12u1DSA-5886-1
Debian:13ruby-rack3.1.12-1DEBIAN-CVE-2025-27111
Debian:14ruby-rack3.1.12-1DEBIAN-CVE-2025-27111
RubyGemsrack3.1.11GHSA-8cgq-6mh2-7j6v
RubyGemsrack2.2.12GHSA-8cgq-6mh2-7j6v
RubyGemsrack3.0.13GHSA-8cgq-6mh2-7j6v
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.2USN-7366-1
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.2UBUNTU-CVE-2025-27111
Ubuntu:25.10ruby-rack3.1.16-0.1UBUNTU-CVE-2025-27111
Ubuntu:26.04:LTSruby-rack3.1.16-0.1UBUNTU-CVE-2025-27111

Affected products (as reported)

VendorProductVersions
rack rack < 2.2.12>= 3.0, < 3.0.13>= 3.1, < 3.1.11

Weakness: CWE-93, CWE-117 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References