Vulnerability · Published May 14, 2025 · Assigned by apache
CVE-2025-26864Apache IoTDB: Exposure of Sensitive Information in IoTDB OpenID Authentication
High 7.5
In plain English
A high-severity information exposure in Apache IoTDB from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB. This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2. Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.iotdb:node-commons | 1.3.4 | GHSA-5fc3-pqf2-57cx |
| Maven | org.apache.iotdb:node-commons | 2.0.2 | GHSA-5fc3-pqf2-57cx |
| PyPI | apache-iotdb | 1.3.4 | PYSEC-2025-60 |
| PyPI | apache-iotdb | 1.3.4 | GHSA-5fc3-pqf2-57cx |
| PyPI | apache-iotdb | 2.0.2 | GHSA-5fc3-pqf2-57cx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache IoTDB | 0.10.0 – through 1.3.32.0.1-beta – before 2.0.2 |
Weakness: CWE-200, CWE-532 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N