Vulnerability · Published Feb 21, 2025 · Assigned by mitre

CVE-2025-26794

High 7.5

In plain English

A high-severity SQL injection in Exim from Exim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 77.6% (higher than 99.6% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)77.6%top 0.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL injection. (Resolving SQL injection requires an update to 4.99.1 in certain non-default rate-limit configurations.)

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13exim44.98-4DEBIAN-CVE-2025-26794
Debian:14exim44.98-4DEBIAN-CVE-2025-26794
Ubuntu:22.04:LTSexim44.95-4ubuntu2.6UBUNTU-CVE-2025-26794
Ubuntu:24.04:LTSexim44.97-4ubuntu4.2UBUNTU-CVE-2025-26794

Affected products (as reported)

VendorProductVersions
Exim Exim 4.98 – before 4.98.1

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References