Vulnerability · Published Feb 18, 2025 · Assigned by GitHub_M
CVE-2025-26623Use After Free in Exiv2
Medium 5.3
In plain English
A medium-severity use-after-free in exiv2 from Exiv2. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are **not** affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fixiso`. The bug is fixed in version v0.28.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | exiv2 | 0.28.3-3.el10_0.2 | ALSA-2025:7457 |
| AlmaLinux:10 | exiv2-devel | 0.28.3-3.el10_0.2 | ALSA-2025:7457 |
| AlmaLinux:10 | exiv2-doc | 0.28.3-3.el10_0.2 | ALSA-2025:7457 |
| AlmaLinux:10 | exiv2-libs | 0.28.3-3.el10_0.2 | ALSA-2025:7457 |
| Alpine:v3.22 | exiv2 | 0.28.5-r0 | ALPINE-CVE-2025-26623 |
| Alpine:v3.23 | exiv2 | 0.28.5-r0 | ALPINE-CVE-2025-26623 |
| Alpine:v3.24 | exiv2 | 0.28.5-r0 | ALPINE-CVE-2025-26623 |
| Debian:13 | exiv2 | 0.28.4+dfsg-2 | DEBIAN-CVE-2025-26623 |
| Debian:14 | exiv2 | 0.28.4+dfsg-2 | DEBIAN-CVE-2025-26623 |
| PyPI | exiv2 | 0.28.5 | GHSA-38h4-fx85-qcx7 |
| PyPI | exiv2 | 0.28.5 | PYSEC-2026-1353 |
| Rocky Linux:10 | exiv2 | 0:0.28.3-3.el10_0.2 | RLSA-2025:7457 |
Affected products (as reported)
Weakness: CWE-416 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-38h4-fx85-qcx7 x_refsource_CONFIRM
- https://github.com/Exiv2/exiv2/issues/3168 x_refsource_MISC