Vulnerability · Published Apr 17, 2025 · Assigned by mitre
CVE-2025-26269
Low 3.3
In plain English
A low-severity security flaw in Dragonfly from DragonflyDB. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).
Severity (CVSS 3.1)3.3Low
Exploit odds (30 days)0.3%top 78.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service (daemon crash) via a Lua library command that references a large negative integer.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| DragonflyDB | Dragonfly | 0 – through 1.28.2 |
Weakness: CWE-191 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L