Vulnerability · Published Feb 10, 2025 · Assigned by apache

CVE-2025-25247Apache Felix Webconsole: XSS in services console

Medium 6.1

In plain English

A medium-severity cross-site scripting in Apache Felix Webconsole from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.7%top 46.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.felix:org.apache.felix.webconsole4.9.10GHSA-4c37-7m5h-c8m9
Mavenorg.apache.felix:org.apache.felix.webconsole5.0.10GHSA-4c37-7m5h-c8m9

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Felix Webconsole Version 4.x – through 4.9.8Version 5.x – through 5.0.8

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References