Vulnerability · Published Feb 14, 2025 · Assigned by GitHub_M
CVE-2025-25206Incorrect input validation could allow an authenticated user to read sensitive information
High 8.3
In plain English
A high-severity SQL injection in elabftw from elabftw. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).
Official description
eLabFTW is an open source electronic lab notebook for research labs. Prior to version 5.1.15, an incorrect input validation could allow an authenticated user to read sensitive information, including login token or other content stored in the database. This could lead to privilege escalation if cookies are enabled (default setting). Users must upgrade to eLabFTW version 5.1.15 to receive a fix. No known workarounds are available.
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/elabftw/elabftw/security/advisories/GHSA-qffc-rfjh-77gg x_refsource_CONFIRM
- https://github.com/elabftw/elabftw/releases/tag/5.1.15 x_refsource_MISC