Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M
CVE-2025-24887OpenCTI bypass of protected attribute update
Medium 6.3
In plain English
A medium-severity improper access control in opencti from OpenCTI-Platform. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | pycti | 6.4.11 | PYSEC-2025-178 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenCTI-Platform | opencti | >= 6.4.8, < 6.4.10 |
Weakness: CWE-284, CWE-657 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L