Vulnerability · Published Jul 31, 2025 · Assigned by apache

CVE-2025-24854Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin

Medium 6.1

In plain English

A medium-severity cross-site scripting in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.5%top 56.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.jspwiki:jspwiki-main2.12.3GHSA-72ww-4rcw-mc62

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache JSPWiki 0 – through 2.12.2

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References