Actively exploited · Published Mar 10, 2025 · Assigned by apache
CVE-2025-24813Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
Critical 10.0 Exploited
In plain English
A critical-severity unsafe deserialization in Apache Tomcat from Apache Software Foundation. Attackers are actively exploiting it in the wild (listed by CISA on April 1, 2025). The chance it is exploited in the next 30 days is estimated at 99.9% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
CISA guidance
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Federal agencies must remediate by Apr 22, 2025.
Official description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | tomcat | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat-admin-webapps | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-admin-webapps | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat-docs-webapp | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-docs-webapp | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-el-3.0-api | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat-el-5.0-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-jsp-2.3-api | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat-jsp-3.1-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:10 | tomcat-lib | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-lib | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-servlet-4.0-api | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat-servlet-6.0-api | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:10 | tomcat-webapps | 1:10.1.36-1.el10_0 | ALSA-2025:7497 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.87-1.el8_10.3 | ALSA-2025:3683 |
| AlmaLinux:9 | tomcat-webapps | 1:9.0.87-2.el9_5.1 | ALSA-2025:3645 |
| AlmaLinux:10 | tomcat9 | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.87-5.el10_0 | ALSA-2025:7494 |
| Debian:12 | tomcat10 | 10.1.34-0+deb12u2 | DEBIAN-CVE-2025-24813 |
| Debian:12 | tomcat10 | 10.1.34-0+deb12u2 | DSA-5893-1 |
| Debian:13 | tomcat10 | 10.1.35-1 | DEBIAN-CVE-2025-24813 |
| Debian:14 | tomcat10 | 10.1.35-1 | DEBIAN-CVE-2025-24813 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-24813 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-24813 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-24813 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.35 | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.3 | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.99 | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat:tomcat-catalina | no fix listed | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat:tomcat-catalina | 9.0.99 | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat:tomcat-catalina | 10.1.35 | GHSA-83qj-6fr2-vhqg |
| Maven | org.apache.tomcat:tomcat-catalina | 11.0.3 | GHSA-83qj-6fr2-vhqg |
| Rocky Linux:10 | tomcat | 1:10.1.36-1.el10_0 | RLSA-2025:7497 |
| Rocky Linux:8 | tomcat | 1:9.0.87-1.el8_10.3 | RLSA-2025:3683 |
| Rocky Linux:9 | tomcat | 1:9.0.87-2.el9_5.1 | RLSA-2025:3645 |
| Rocky Linux:10 | tomcat9 | 1:9.0.87-5.el10_0 | RLSA-2025:7494 |
| Ubuntu:25.10 | tomcat9 | 9.0.70-2ubuntu2 | UBUNTU-CVE-2025-24813 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.210.1.0-M1 – through 10.1.349.0.0.M1 – through 9.0.988.5.0 – through 8.5.100 |
Weakness: CWE-44, CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq vendor-advisory
- http://www.openwall.com/lists/oss-security/2025/03/10/5
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce
- https://security.netapp.com/advisory/ntap-20250321-0001/
- https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability
- https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md exploit
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813 government-resource