Vulnerability · Published Jan 29, 2025 · Assigned by GitHub_M
CVE-2025-24794The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
Medium 6.7
In plain English
A medium-severity unsafe deserialization in snowflake-connector-python from snowflakedb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | snowflake-connector-python | 3.13.1 | GHSA-m4f6-vcj4-w5mx |
| PyPI | snowflake-connector-python | 3.13.1 | PYSEC-2025-27 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| snowflakedb | snowflake-connector-python | >= 2.7.12, < 3.13.1 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H