Vulnerability · Published Jan 29, 2025 · Assigned by GitHub_M

CVE-2025-24790Snowflake JDBC uses insecure temporary credential cache file permissions

Medium 4.4

In plain English

A medium-severity incorrect default permissions in snowflake-jdbc from snowflakedb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.2%top 91.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Snowflake JDBC provides a JDBC type 4 driver that supports core functionality, allowing Java program to connect to Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavennet.snowflake:snowflake-jdbc3.22.0GHSA-33g6-495w-v8j2

Affected products (as reported)

VendorProductVersions
snowflakedb snowflake-jdbc >= 3.6.8, < 3.22.0

Weakness: CWE-276 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

References