Vulnerability · Published Jan 29, 2025 · Assigned by GitHub_M

CVE-2025-24374Twig fixes a security issue where escaping was missing when using null coalesce operator (??)

Medium 4.3

In plain English

A medium-severity injection in Twig from twigphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.3%top 77.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Twig is a template language for PHP. When using the ?? operator, output escaping was missing for the expression on the left side of the operator. This vulnerability is fixed in 3.19.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-twigno fix listedDEBIAN-CVE-2025-24374
Debian:13php-twig3.19.0-1~bootstrapDEBIAN-CVE-2025-24374
Debian:14php-twig3.19.0-1~bootstrapDEBIAN-CVE-2025-24374
Packagisttwig/twig3.19.0GHSA-3xg3-cgvq-2xwr

Affected products (as reported)

VendorProductVersions
twigphp Twig >= 3.16.0, < 3.19.0

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

References