Vulnerability · Published Jan 27, 2025 · Assigned by GitHub_M

CVE-2025-24354imgproxy is vulnerable to SSRF against 0.0.0.0

Medium 5.3

In plain English

A medium-severity server-side request forgery in imgproxy from imgproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.9%top 40.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling2Nuclei, Public PoC

Official description

imgproxy is server for resizing, processing, and converting images. Imgproxy does not block the 0.0.0.0 address, even with IMGPROXY_ALLOW_LOOPBACK_SOURCE_ADDRESSES set to false. This can expose services on the local host. This vulnerability is fixed in 3.27.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/imgproxy/imgproxy3.27.2GHSA-j2hp-6m75-v4j4
Gogithub.com/imgproxy/imgproxyno fix listedGO-2025-3422
Gogithub.com/imgproxy/imgproxy/v2no fix listedGO-2025-3422
Gogithub.com/imgproxy/imgproxy/v33.27.2GO-2025-3422

Affected products (as reported)

VendorProductVersions
imgproxy imgproxy < 3.27.2

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References