Vulnerability · Published Mar 3, 2025 · Assigned by GitHub_M
CVE-2025-24023Observable Response Discrepancy in flask-appbuilder
Low 3.7
In plain English
A low-severity security flaw in Flask-AppBuilder from dpgaspar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 73.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Flask-AppBuilder is an application development framework. Prior to 4.5.3, Flask-AppBuilder allows unauthenticated users to enumerate existing usernames by timing the response time from the server when brute forcing requests to login. This vulnerability is fixed in 4.5.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | flask-appbuilder | 4.5.3 | GHSA-p8q5-cvwx-wvwp |
| PyPI | flask-appbuilder | 4.5.3 | PYSEC-2025-15 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dpgaspar | Flask-AppBuilder | < 4.5.3 |
Weakness: CWE-204 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N