Vulnerability · Published Jan 17, 2025 · Assigned by GitHub_M

CVE-2025-23207\htmlData does not validate attribute names in KaTeX

Medium 6.3

In plain English

A medium-severity security flaw in KaTeX from KaTeX. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.4%top 64.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-katexno fix listedDEBIAN-CVE-2025-23207
Debian:13node-katexno fix listedDEBIAN-CVE-2025-23207
Debian:14node-katex0.16.10+~cs6.1.0-7DEBIAN-CVE-2025-23207
Ubuntu:25.10node-katex0.16.10+~cs6.1.0-2ubuntu1UBUNTU-CVE-2025-23207
Ubuntu:26.04:LTSnode-katex0.16.10+~cs6.1.0-2ubuntu1UBUNTU-CVE-2025-23207
npmkatex0.16.21GHSA-cg87-wmx4-v546

Affected products (as reported)

VendorProductVersions
KaTeX KaTeX >= 0.12.0, < 0.16.21

Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References