Vulnerability · Published Oct 31, 2025 · Assigned by mitre

CVE-2025-23050

Low 3.1

In plain English

A low-severity out-of-bounds read in Qt from Qt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.1Low
Exploit odds (30 days)0.2%top 91.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

QLowEnergyController in Qt before 6.8.2 mishandles malformed Bluetooth ATT commands, leading to an out-of-bounds read (or division by zero). This is fixed in 5.15.19, 6.5.9, and 6.8.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12qt6-connectivityno fix listedDEBIAN-CVE-2025-23050
Debian:13qt6-connectivity6.7.2-8DEBIAN-CVE-2025-23050
Debian:14qt6-connectivity6.7.2-8DEBIAN-CVE-2025-23050
Debian:12qtconnectivity-opensource-srcno fix listedDEBIAN-CVE-2025-23050
Debian:13qtconnectivity-opensource-src5.15.15-3DEBIAN-CVE-2025-23050
Ubuntu:22.04:LTSqt6-connectivityno fix listedUBUNTU-CVE-2025-23050
Ubuntu:24.04:LTSqt6-connectivityno fix listedUBUNTU-CVE-2025-23050
Ubuntu:22.04:LTSqtconnectivity-opensource-srcno fix listedUBUNTU-CVE-2025-23050
Ubuntu:24.04:LTSqtconnectivity-opensource-srcno fix listedUBUNTU-CVE-2025-23050
Ubuntu:25.10qtconnectivity-opensource-srcno fix listedUBUNTU-CVE-2025-23050

Affected products (as reported)

VendorProductVersions
Qt Qt 0 – before 5.15.196.0.0 – before 6.5.96.6.0 – before 6.8.2

Weakness: CWE-125 · Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

References