Vulnerability · Published Jan 15, 2025 · Assigned by GitHub_M
CVE-2025-22146Improper authentication on SAML SSO process allows user impersonation in sentry
Critical 9.1
In plain English
A critical-severity improper authentication in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | sentry | 25.1.0 | GHSA-7pq6-v88g-wf3w |
| PyPI | sentry | 25.1.0 | PYSEC-2026-532 |
Affected products (as reported)
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-7pq6-v88g-wf3w x_refsource_CONFIRM
- https://github.com/getsentry/sentry/pull/83407 x_refsource_MISC