Vulnerability · Published Mar 11, 2025 · Assigned by VulDB

CVE-2025-2177libzvbi search.c vbi_search_new integer overflow

High 7.3

In plain English

A high-severity integer overflow in libzvbi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.6%top 48.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zvbi0.2.41-1+deb12u1DEBIAN-CVE-2025-2177
Debian:13zvbi0.2.44-1DEBIAN-CVE-2025-2177
Debian:14zvbi0.2.44-1DEBIAN-CVE-2025-2177

Affected products (as reported)

VendorProductVersions
n/a libzvbi 0.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.7

Weakness: CWE-190, CWE-189 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References