Vulnerability · Published Mar 11, 2025 · Assigned by VulDB

CVE-2025-2175libzvbi _vbi_strndup_iconv integer overflow

Medium 4.3

In plain English

A medium-severity integer overflow in libzvbi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.6%top 50.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zvbi0.2.41-1+deb12u1DEBIAN-CVE-2025-2175
Debian:13zvbi0.2.44-1DEBIAN-CVE-2025-2175
Debian:14zvbi0.2.44-1DEBIAN-CVE-2025-2175

Affected products (as reported)

VendorProductVersions
n/a libzvbi 0.2.00.2.10.2.20.2.30.2.40.2.50.2.60.2.7

Weakness: CWE-190, CWE-189 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

References