Vulnerability · Published Nov 25, 2025 · Assigned by GitHub_M

CVE-2025-21621GeoServer Reflected Cross-Site Scripting (XSS) vulnerability in WMS GetFeatureInfo HTML format

Medium 6.1

In plain English

A medium-severity cross-site scripting in geoserver from geoserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 75.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.geoserver.web:gs-web-app2.25.0GHSA-w66h-j855-qr72
Mavenorg.geoserver:gs-wms2.25.0GHSA-w66h-j855-qr72

Affected products (as reported)

VendorProductVersions
geoserver geoserver < 2.25.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References