Vulnerability · Published Jan 6, 2025 · Assigned by GitHub_M

CVE-2025-21612Cross-site Scripting in TabberTransclude in Extension:TabberNeue

High 8.6

In plain English

A high-severity cross-site scripting in mediawiki-extensions-TabberNeue from StarCitizenTools. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.5%top 56.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagiststarcitizentools/tabber-neue2.7.2GHSA-4x6x-8rm8-c37j

Affected products (as reported)

VendorProductVersions
StarCitizenTools mediawiki-extensions-TabberNeue >= 1.9.1, < 2.7.2>= d8c3db4e5935476e496d979fb01f775d3d3282e6, < f229cab099c69006e25d4bad3579954e481dc566

Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

References