Vulnerability · Published Dec 14, 2025 · Assigned by VulDB
CVE-2025-14691Mayan EDMS authentication cross site scripting
Medium 4.3
In plain English
A medium-severity cross-site scripting in EDMS from Mayan. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | mayan-edms | 4.10.2 | GHSA-774q-r975-vqwp |
| PyPI | mayan-edms | 4.9.7 | GHSA-774q-r975-vqwp |
| PyPI | mayan-edms | 4.8.10 | GHSA-774q-r975-vqwp |
| PyPI | mayan-edms | 4.7.8 | GHSA-774q-r975-vqwp |
| PyPI | mayan-edms | 4.6.12 | GHSA-774q-r975-vqwp |
| PyPI | mayan-edms | 4.10.2 | PYSEC-2025-134 |
Affected products (as reported)
Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-336409 | Mayan EDMS authentication cross site scripting vdb-entry
- VDB-336409 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #711713 | Mayan EDMS CMS 4.10 Cross Site Scripting third-party-advisory
- https://github.com/ionutluca888/Mayan-EDMS-XSS-POC exploit
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html patch
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html#security patch