Vulnerability · Published Jan 23, 2026 · Assigned by Wordfence
CVE-2025-13921weDocs <= 2.1.16 - Missing Authorization to Authenticated (Subscriber+) Documentation Post Update
Medium 4.3
In plain English
A medium-severity missing authorization in weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot from wedevs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).
Official description
The weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot plugin for WordPress is vulnerable to unauthorized modification or loss of data due to a missing capability check on the 'wedocs_user_documentation_handling_capabilities' function in all versions up to, and including, 2.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit any documentation post. The vulnerability was partially patched in version 2.1.16.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| wedevs | weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot | 0 – through 2.1.16 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c56234f3-7dd6-4dff-887d-5ddbf0cb7d3c?source=cve
- https://plugins.trac.wordpress.org/browser/wedocs/tags/2.1.14/includes/functions.php#L506
- https://plugins.trac.wordpress.org/browser/wedocs/tags/2.1.14/includes/Installer.php#L21
- https://plugins.trac.wordpress.org/changeset/3426704/
- https://plugins.trac.wordpress.org/changeset/3440068/