Vulnerability · Published Nov 11, 2025 · Assigned by NETGEAR

CVE-2025-12944Improper input validation in NETGEAR DGN2200v4

Medium 6.8

In plain English

A medium-severity improper input validation in DGN2200v4 from NETGEAR. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities).

Severity (CVSS 4.0)6.8Medium
Exploit odds (30 days)0.3%top 81.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in:  DGN2200v4 firmware 1.0.0.132 or later

Affected products (as reported)

VendorProductVersions
NETGEAR DGN2200v4 0 – through 1.0.0.126

Weakness: CWE-20 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/AU:N/R:A/V:D/RE:L/U:Amber

References